Captions upload

Resolved
Degraded performance
Started almost 3 years ago Lasted 3 months

Affected

Website
Updates
  • Resolved
    Resolved

    We have updated the upload design and fixed the issue

  • Monitoring
    Monitoring

    The caption upload form doesn't work unless you reload the page. We're currently working on a solution for this.