Server update

Resolved
Under maintenance
Started about 3 years ago Lasted about 1 hour

Affected

Website
Updates
  • Resolved
    Resolved

    Website is now operational! Security fixes and speed improvements have been added as well

  • Identified
    Identified

    Website cannot be accessed at the moment. This incident was caused by a server update